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Introduction
FlukeView® Forms Documenting Software gives you the ability to easily document, analyze
and save measurements acquired by a FlukeView Forms compatible instrument (like a Fluke 89
DMM). FlukeView Forms software uses FlukeView standard forms or custom-created forms to
record, chart and graph measurement data. With the FlukeView Forms Designer you can create
professional looking forms that you or others can use to document and analyze measurement
data. This technical note gives a step by step process for creating a professional looking form.

The FlukeView Forms Designer creates form templates.  Each form in the FlukeView Forms
application is based on a form template; when choosing a new form in FlukeView Forms, you
select the form you want to enter meter data into from a list of form templates.  You can design
custom form templates to display measurement data and your own comments and company
information just the way you want to.

Survey FlukeView Standard Forms
To get an idea of what a FlukeView Forms form template looks like:

• Startup FlukeView Forms (without connecting it to a meter).

• Click OK on the prompt for no instrument connected.

• Under the File menu, select "Open Database…"

• Open the file named sample.fdb.

• In the top left corner of the FlukeView Forms window, underneath the menu bar there is
a drop-down list labeled "Select a form".  This lists all of the form templates in this
database.  Select each form template in the list; a form based on this form template will
be displayed by FlukeView Forms.

• You may print out the forms by selecting Print under the File menu.



Creating a Rough Draft Prototype of your Form Template
Before creating a new form, you need to have an idea of what your new form template should
look like. If you have already used a FlukeView Forms standard form to load and view
measurement data with -- particularly the type of data that you want to view with your custom
form template -- then that template is a good starting place.  It can be a prototype of the custom
form template you want to build.

In the standard FlukeView forms there are several different kinds of objects that are used to
document different types of information or show a visual representation of that information.
These objects are called form items. To find out more information on these form items, see the
section in the FlukeView Forms User's Manual titled "Altering Form Templates".

It will be helpful if you write down the kind of information that needs to be recorded. Now you
can put together a rough draft of what you want your form to look like. For this technical note
our rough draft is the FlukeView standard form titled "Sample Line Voltage Form". It will be
helpful if you have a printed copy of that form (see the previous section, “Survey FlukeView
Standard Forms”).

Starting FlukeView Form Designer
• Click on the Windows Start button

• Go to Programs->Fluke->FlukeView Forms and select FlukeView Forms Designer.

Layout Menu
• Click on Layout in the menu bar

• Select Form Properties

• Click on help button to get an idea what each of the fields mean

• Leave the boxes blank and fill in the form description with "Line Voltage Test"

• Click OK

• Click on Layout in the menu bar and select Page Setup

• Make sure that the correct paper size is selected for your printer

• Click OK and then Click OK once more

• Click on Layout in the menu bar and select Number of Pages

• In this case we will leave the number of pages at 1



General Process for Creating Form Items on a Form Page
A FlukeView form is created by placing FlukeView Forms form items on a blank form template.
The rough draft form discussed above is used to help in organizing the placement of each
FlukeView Form Item. In general, placing a form item onto a form follows the following
process:

1. Selecting the form item

• If the FlukeView Form Item List selection box is not already showing click on View in
menu bar and select Form Item List

• Select the desired FlukeView Form Item

• Click Insert

• The form item will appear in the upper right hand section of the form page or sheet

2. Changing items in form property page

• Right click on the inside of the form item

• Click on the properties pop up button

• Change property values as needed (click on help button for help on property parameters)

• Click OK

3. Move form item to desired position on form page

• 

• Move the cursor over the hashed outline of the form item (but not over a resize handle
discussed in the next section). The cursor will turn into two double ended arrows that

cross each other 

• Click and hold down the left mouse key and drag the form item outline to the position
shown in your sketched out prototype form (see "Creating a Rough Draft Prototype
Form" earlier in this technical note)

4. Resize form item to desired size

There are three ways that a form item can be resized, stretched or shrunk: horizontally, vertically,
or diagonally. Which resize method is used depends on which resize handle is dragged. The
resize handles are small squares located along the edges of the form item. Dragging a handle
located in the middle of the outline’s side will allow you to drag that side either vertically or
horizontally. Dragging a handle located in one of the corners will allow you to drag that corner in
any direction.



• Move the cursor over one of the form item’s resize handles. The cursor will turn into a

double ended arrow 

• Click and hold down the left mouse key. Drag the cursor until the desired amount of
resizing is obtained. Release the mouse key

Getting a Company Logo Bitmap
If you would like to have a company logo on your form, you will need to get a graphic file (a
.bmp, .gif or .jpg file) of the logo; or follow the simple procedure given below to have a bitmap
file created for you. Using a web browser and your company’s home web page makes it easy to
create a logo bitmap. (If you do not have assess to a web browser, then skip this section and go to
the next section, "Company Logo."

• Start up your favorite web browser

• Go to your company’s home page (or some other web page with a logo that you like)

• Put the cursor over the bitmap that you would like to have copied into a bitmap file

• Right click mouse key

• Select "Save Picture as …" and select the folder where you want the bitmap to be saved

• Change the file name to "Company Logo" (*.gif, *.bmp or *.jpg formats are fine)

• Click on Save

Company Logo 
• Select the FlukeView Bitmap form item from the Form Item List, insert the form item

and bring up its property page

• Click on the Pictures tab

• Click on the Browse button. Under "Files of type" select "All files (*.*)". [The selection
"All Picture Types" will find *.bmp files but not *.jpg files]

• In "Look in" find the folder where you saved your company logo bitmap. Select that file
and click Open

• Click OK

• Resize the bitmap form item until the company logo fits within the bitmap box

• Move the logo into the position shown in the rough draft form



Form Title
• Select the FlukeView Label form item from the Form Item List, insert the form item and

bring up its property page

• Under "Label text" type in the title of your form, in this example: "Line Voltage Test
Report"

• Click on the Fonts tab and change the font size to 16

• Just for fun, click the Colors tab. Remember the System color in case you want to return
to that value. Now select a different background color, like yellow (click Apply to check
out what the background looks like)

• Click OK

• Resize and position the label item

Date Time Stamp 
• Select the FlukeView Date Time Stamp form item from the Form Item List, insert the

form item and bring up its property page

• Click on help to get an understanding of the options available. We will use the default
settings. Click OK

• Position the Date Time Stamp item

Instrument Meter Identification 
Now do the same for the Meter Identification form item as you did for the Date Time Stamp
form item, using the default settings.

Selection Box for Technician Name 
• Select the FlukeView Selection Box form item from the Form Item List, insert the form

item and bring up its property page

• Click on the Help button to get an idea of what the options are used for and then exit help

• Change the label to "Test Technician"

• In the Selection List box, enter the list of technician names to be used as selection items

• Enter in the default value you would like to appear in the form the first time it is used. If
you are the only technician then enter your name here. Another common thing to put here
is "Type or Select Your Name"



• Click on OK

• Move the selection box item to the position indicated by your prototype form. Place the
form item outline’s left hand edge approximately where you want that edge to be located

• Move the cursor towards the center of the selection box item, until it is over the solid
vertical line and the cursor turns into a double ended arrow with a bar through the arrow.
Drag that vertical edge of the solidly outlined rectangle until the label fits inside the label
area. You may have to repeat this step a few more times

• Now drag the form item’s right edge until it is wide enough to hold any of the selected or
typed in names. Left click on the selection box down arrow. This will allow you to check
if the window is wide enough. Repeat this step as needed

Memo Box
• Select the FlukeView Memo form item from the Form Item List, insert the form item and

bring up its property page

• Move the memo form item until its upper left hand corner is located approximately where
your rough draft form indicates

• Using the lower right corner resizing handle, drag it until the memo item fills up the
desired area

Logged Readings Graph
• Select the FlukeView Logged Readings Graph form item from the Form Item List, insert

the form item and bring up its property page

• We will use the default properties, but you should explore the properties pages. Click on
the tabs and help button to see what you can do with scales and axis labels. Click on
cancel to get out of properties. If the scale values are too small for you, go back to the
properties page and select large under Text size

• Follow same steps as those in the Memo form item to position and resize the Logged
Readings Graph form item

Event Amplitude Histogram
• Follow directions given for Logged Readings Graph except use the Event Amplitude

Histogram form item

Logged Readings Table
• Select the FlukeView Logged Readings Table form item from the Form Item List, insert

the form item and bring up its property page



• Using the scroll bar and down arrow on the side of the edit window (normally on the far
right hand side of the FlukeView Form Designer window) scroll the form page down
until the top of the logged readings table form is near the top of the edit window

• Move the top of the logged readings table form straight down to the bottom of the edit
window (the cursor needs to be the two double arrows that cross each other)

• Repeat the previous two steps until the top of the logged readings table form is located
under the FlukeView Logged Readings Graph and FlukeView Event Amplitude
Histogram in a position shown in your rough draft form

• Click and hold down the left mouse key on the position indicator in the scroll bar (on the
far right hand side) and drag the position indicator until the bottom of the logged reading
table is at the top of the edit screen or the position indicator is at the bottom of the scroll
bar

• Click on the scroll bar that appears on the bottom of the logged readings table form item.
This causes the resize handles to appear at the bottom of that form

• Move the cursor over the center resizing handle on the bottom of the logged reading table
item

• Click and hold the left mouse key and drag the bottom of the table form item to the
bottom of the edit page

• Bring up the logged reading table properties page and change the number of rows to 200

Saving your Custom FlukeView Form Section
It is recommended that you create a new database file to save the newly created form into,
instead of using the sample data base file.

• Under File in the menu bar, select New Database…

• Enter in your own database name in the File name box and click OK

• Click Yes on the dialog question "Save changes to Untitled?"

• In the Form name box enter "Line Voltage Form" and click OK

Using your new Custom FlukeView Form Template
You now have a form template that you can use to document and analyze acquired data

• Startup FlukeView Forms.

• Under the File menu, select Open Data Base

• Open the file named for the data base that you created in the "Saving your Custom



FlukeView Form Template" section

• Select "New Blank Form…" from the File Menu

• You will find the form template you just created in the list.  Select your template and then
click on "OK"

FlukeView Forms is now ready to load data into a form based on your custom form template.
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